Opened 5 years ago

Closed 5 years ago

#730 closed defect (worksforme)

Youtube videos embedded in facebook show ads - Safari

Reported by: rodogu Assignee:
Priority: P3 Milestone:
Module: Platform Keywords:
Cc: sebastian Blocked By:
Blocking: Platform: Safari
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

OS X 10.9.3, Safari 7.0.4, AdblockPlus 1.8.3

How to reproduce

When viewing Facebook embedded youtube videos, I still get ads :(

http://cl.ly/image/2o1Z0v1q2P3G/Facebook%202014-06-27%2011-26-30%202014-06-27%2011-34-54.jpg

http://cl.ly/image/211y3s0E1E0F/Facebook%202014-06-27%2011-38-26%202014-06-27%2011-39-17.jpg

P.S. There is no component for Adblock-Plus-for-Safari

Change History (6)

comment:1 Changed 5 years ago by arthur

  • Platform set to Safari

comment:2 Changed 5 years ago by sebastian

  • Cc sebastian added
  • Component changed from Unknown to Platform
  • Priority changed from Unknown to P3

Do you get the HTML5 or Flash player? What's the URL of the frame that embeds the player?

If you are not familiar with web development, you can just press Ctrl + Shift + C, click the video and take a screenshot.

comment:3 Changed 5 years ago by rodogu

Sebastian,

That's with flash, and I see the ads.

I just switched to HTML5, and in a couple of embedded videos I didn't see the ads. Is it then a flash-only issue?

Will report back if I ever see ads with HTML5 embedded videos.

Thanx!

comment:4 Changed 5 years ago by sebastian

Ads are blocked differently with YouTube's flash player, than with its HTML5 player. However, there are some cases where we can't block ads when using the HTML5 player, since you can't block XMLHttpRequests on Safari.

Is there any URL where I can reproduce the issue (without creating a Facebook account)?

comment:5 Changed 5 years ago by eliperkins

I can reproduce this as well, but on 10.10, Safari 8, and even with 1.8.3.1204 nightly build.

Especially notice it on sites like plug.dj that rely on YT embeds on music videos.

comment:6 Changed 5 years ago by sebastian

  • Resolution set to worksforme
  • Status changed from new to closed

Feel free to reopen the issue, providing a URL to a public website, embedding YouTube's Flash player, showing ads.

For ads not beeing blocked with YouTube's HTML5 player see #1258.

Note: See TracTickets for help on using tickets.