Changes between Version 33 and Version 36 of Ticket #7305


Ignore:
Timestamp:
03/18/2019 04:15:30 PM (7 months ago)
Author:
kzar
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #7305

    • Property Status changed from reviewing to closed
    • Property Resolution changed from to fixed
    • Property Milestone changed from to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Ticket #7305 – Description

    v33 v36  
    5454=== Further information === 
    5555Chrome doesn't notify us of the anonymous frame with the `srcdoc` attribute. Therefore the extension doesn't know which frame the ad.htm request originated from. Due to that the exception rule is not applied and the request gets blocked. [https://bugs.chromium.org/p/chromium/issues/detail?id=937264 See Chromium issue 937264]. 
     56 
     57=== Hints for testers === 
     58Any time we touch the page-frame hierarchy code, it's possible to cause regressions. There's a lot of complexity, and subtleties with timing etc which are hard to get right. We need to thoroughly test blocking, element hiding and whitelisting. Things like `$sitekey` whitelisting, adverts in nested frames, different browsers + versions, that we didn't reintroduce previously fixed bugs in this code (#7065, #6953, #6808, #6746, #6692, #6595, #6191 etc).