Opened 9 months ago

Closed 3 months ago

#7310 closed defect (rejected)

Acceptable Ads state sometimes not applied correctly?

Reported by: Ross Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: sebastian, kzar, greiner Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by Ross)

Environment

ABP 3.4.3.2258

Opera 57 / Windows 10
Chrome 72 / Windows 10

NOT a regression compared to 3.4.3 (Previous release)

How to reproduce

  1. Search for https://www.google.com/search?q=buy+iphone
  2. Refresh the page a few times.
  3. Turn off AA.
  4. Refresh the search a few times.
  5. Turn on AA.
  6. Refresh the search a few times.
  7. Repeat steps 2-6 a lot.

Observed behaviour

Sometimes, with Acceptable Ads off, there are still [Ad] elements at the top of the search results and the [Sponsored] section still appears.

Also sometimes, with Acceptable Ads on, all of the [Ad] elements at the top of the search results and the [Sponsored] section are missing.

Expected behaviour

These ads to be hidden when AA is off and displayed when AA is on.

Change History (7)

comment:1 Changed 9 months ago by Ross

This might not be a bug, but I'm pretty sure it is.

I first noticed this in Opera, then could eventually reproduce something similar in Edge. I could also reproduce something similar again in Chrome/Firefox but with much more difficulty.

It can take several/many refreshes and/or adding/disabling of the AA list to reproduce.

comment:2 Changed 9 months ago by kzar

Can you reproduce it with the previous release?

comment:3 Changed 9 months ago by kzar

  • Component changed from Unknown to Platform

comment:4 Changed 9 months ago by Ross

  • Description modified (diff)

I can reproduce it in the previous release.

comment:5 Changed 9 months ago by Ross

I'm still not sure if this is a bug, or if I'm misunderstanding what should/should not be blocked with the AA list on/off.

comment:6 Changed 9 months ago by greiner

  • Cc greiner added

I can only reproduce the part where the ads don't reappear when turning Acceptable Ads back on. Looking at the DOM, this appears to be done by Google itself. Because rather than simply being hidden, the ads aren't even in the DOM in this particular case.

comment:7 Changed 3 months ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.