Opened 5 months ago

Closed 5 months ago

#7311 closed change (fixed)

Fix performance regression introduced in changeset 0da36169b1a4 (#7267)

Reported by: mjethani Assignee: mjethani
Priority: P2 Milestone:
Module: Core Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/30018555/

Description (last modified by mjethani)

Background

After changset 0da36169b1a4 the _checkEntryMatch() function takes longer. It is not clear why this is, but it is possibly because of the additional lines of code that cause the function to be deoptimized on V8.

What to change

Split _checkEntryMatchByDomain() into two smaller functions for the Filter and Map cases.

Hints for testers

Same as #7265.

Change History (5)

comment:1 Changed 5 months ago by mjethani

  • Blocking 7000 removed

comment:2 Changed 5 months ago by abpbot

A commit referencing this issue has landed:
Issue 7311 - Split _checkEntryMatchByDomain()

comment:3 Changed 5 months ago by mjethani

  • Description modified (diff)

comment:4 Changed 5 months ago by mjethani

  • Description modified (diff)
  • Ready set

comment:5 Changed 5 months ago by mjethani

  • Resolution set to fixed
  • Review URL(s) modified (diff)
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.