Opened 4 months ago

Last modified 4 months ago

#7335 new defect

Subscription links sometimes do not work in Edge

Reported by: Ross Assignee:
Priority: P3 Milestone:
Module: Unknown Keywords:
Cc: sebastian, kzar, geo, greiner Blocked By:
Blocking: Platform: Edge
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

ABP 0.9.13.2260
Edge 44.17763.1.0

Seems to be a regression compared to 0.9.13. I haven't reproduced it in 0.9.13, however it might be present.

How to reproduce

  1. Go to https://testpages.adblockplus.org/
  2. Select [Subscribe].

Possible other steps/setup:

  • Try just after installing.
  • Try having "Clear data when closing browser" option selected, install, wait a few minutes, close browser, wait a minute, open browser, try subscription.

Observed behaviour

The subscribe link either:

A) Works as expected (Most of the time).

B) Opens the ABP Settings page, but does not display the overlay, with these errors (either one or both) in the console:

SCRIPT6: The handle is invalid. common.js (41,9)

The handle is invalid. messageResponder.js (113,1)

C) Acts as if no abp: handler is installed at all, and asks the user if they want to find an app from the app store.

Expected behaviour

The subscribe link to work all of the time.

Change History (2)

comment:1 Changed 4 months ago by geo

I've tried both methods (many times) and every time I keep getting the A) scenario.

However, I have encountered the C) scenario, maybe once or twice, but I assumed that it was more of a Edge sync problem (since I was doing the install/uninstall very frequently), for instance the ABP icon was still being displayed after an uninstall and then when reinstalling it would be displayed twice.

The error message that you are reporting we've seen before, but back then it was in the context of the ui port disconnect event not triggering when you would close the options page, so the second time you would open the options page the ui would be unresponsive.

I'll keep on trying to reproduce this on other devices as well, maybe I'll manage to reproduce it on one.

comment:2 Changed 4 months ago by sebastian

  • Priority changed from Unknown to P3
  • Ready set

I was able to reproduce the options page showing without the dialog (B) once, right after starting Microsoft Edge and going to https://testpages.adblockplus.org with the Adblock Plus development build (0.9.13.2258) already installed. I was not able to reproduce it a second time. After reinstalling the Adlbock Plus development build once, Adblock Plus didn't seem to load, hence subscribe: links behaved like they do when Adblock Plus is not installed (C), until I restarted Microsoft Edge. However, I wasn't able to reproduce this again either, after subsequent reinstalls everything worked as expected.

FWIW, the latter (C) is probably an issue in Microsoft Edge itself we cannot do anything about on our end. My best guess for the other scenario (B) is that it might be a timing issue that may have become more likely to trigger in recent versions due to unrelated changes affecting the performance. But it still seems to happen very rarely, which makes it difficult to debug.

Anyway, let's not consider this a blocker for the upcoming 0.9.14 release.

Note: See TracTickets for help on using tickets.