Opened 9 months ago

Closed 7 months ago

Last modified 2 months ago

#7347 closed defect (fixed)

Notification animations error on Edge

Reported by: Ross Assignee: geo
Priority: P3 Milestone: Adblock-Plus-for-Chrome-Opera-Firefox-next
Module: Unknown Keywords:
Cc: sebastian, kzar, geo Blocked By:
Blocking: Platform: Edge
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://gitlab.com/eyeo/adblockplus/adblockpluschrome/merge_requests/73

Description (last modified by geo)

Environment

ABP 0.9.13.2261
Edge 44.17763.1.0 / Windows 10

NOT a regression compared to 0.9.13 Edge release.

How to reproduce

  1. Serve notification file below.
  2. Install ABP.
  3. Inspect the ABP popup, in the console run:

browser.runtime.sendMessage({type: "prefs.set", key: "notificationurl", value: "http://urlto.the/notification.json"})

  1. Wait 60s until you see notification has been requested.

Test notification

{
  "notifications": [
    {
      "id": "information_onelink",
      "severity": "information",
      "links": [
        "adblock_browser_promotion_0"
      ],
      "title": {
        "en-US": "Test Information Notification",
        "de": "DE Test Information Notification"
      },
      "message": {
        "en-US": "This is a <a>test</a> information notification.",
        "de": "DE This is a <a>test</a> information notification."
      }
    }
  ],
  "version": "201810011538"
}

Observed behaviour

The follow error appears in the console, while attempting to animate the notification:

SCRIPT5022: SCRIPT5022: Error: Invalid value for argument 1. Property 'imageData': Unexpected property, Property 'path': Property is required.
adblockplus.js (11092,13)

3360: Error: Invalid value for argument 1. Property 'imageData': Unexpected property, Property 'path': Property is required.

Expected behaviour

The error not to be logged to the console and icon animations to work as expected. The information notification should animate a ?, the critical notification should animate a !.

Hints for testers

Due to API limitations, we can't have the same nice animation as with the other browsers, instead we just toggle between icons.

Change History (12)

comment:1 Changed 9 months ago by Ross

  • Description modified (diff)

comment:2 Changed 9 months ago by sebastian

Is this a duplicate of #5746?

comment:3 follow-up: Changed 7 months ago by geo

Edge doesn't support imageData. A workaround would be to toggle between the normal icon and the notification icon, skipping the fade effect.

Also regarding 5746 I don't think that this ticket is a duplicate, I had some issues seeing the notifications a few times, but I'm using a different setup and I think that was the problem.

comment:4 Changed 7 months ago by sebastian

That makes sense. The suggested workaround sounds reasonable to me.

comment:5 Changed 7 months ago by sebastian

  • Priority changed from Unknown to P3
  • Ready set

comment:6 in reply to: ↑ 3 ; follow-up: Changed 7 months ago by kzar

Replying to geo:

Edge doesn't support imageData.

What about the new Chromium-based Edge?

comment:7 in reply to: ↑ 6 Changed 7 months ago by Ross

Replying to kzar:

Replying to geo:

Edge doesn't support imageData.

What about the new Chromium-based Edge?

The icon animations work as expected (just like Chrome) as far as I can tell in 76.0.159.0 / Edge Chromium.

comment:8 Changed 7 months ago by geo

  • Owner set to geo
  • Review URL(s) modified (diff)

comment:9 Changed 7 months ago by abpbot

comment:10 Changed 7 months ago by geo

  • Description modified (diff)
  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Resolution set to fixed
  • Status changed from new to closed

comment:11 Changed 5 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. Notification animations work on all platforms.

ABP 0.9.15.2339
Microsoft Edge 44.17763.1.0 / Windows 10 1809

ABP 3.5.2.2339
Chrome 49.0.2623.75 / Windows 10 1809
Chrome 75.0.3770.142 / Windows 10 1809
Opera 36.0.2130.65 / Windows 10 1809
Opera 62.0.3331.72 / Windows 10 1809
Firefox 51.0 / Windows 10 1809
Firefox 68.0 / Windows 10 1809

comment:12 Changed 3 months ago by booms1

spam

Last edited 2 months ago by kzar (previous) (diff)
Note: See TracTickets for help on using tickets.