Opened 9 months ago

Closed 4 months ago

#7348 closed defect (duplicate)

Firefox Issue Reporter not working

Reported by: jparedes Assignee:
Priority: Unknown Milestone:
Module: User-Interface Keywords:
Cc: greiner, agiammarchi Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Within Firefox on Mac and Windows and Adblock Plus 3.4.3

How to reproduce

  1. Click on ABP Icon and "Report an Issue"
  2. Click I still see Ads
  3. Highlight Ads
  4. Step three of the Issue Reporter, type in your email-address

Observed behaviour

For some users, when typing in the email-address the "Continue" Button does not activate and stays light-blue

Expected behaviour

The "Continue" Button should activate and lead to step four.

Change History (4)

comment:1 Changed 9 months ago by greiner

  • Cc greiner added
  • Component changed from Unknown to User-Interface

comment:2 Changed 9 months ago by greiner

  • Cc agiammarchi added

I'm unable to reproduce this issue using:

Adblock Plus 3.4.3 and latest devbuild
Firefox 66
Ubuntu 18.10

There are a couple of requirements that need to be met for the Send button to become active:

Either

  1. "Anonymous submission" is checked
  2. Issue reporter has been open for at least five seconds (or background tab has finished loading)

or

  1. Email field is not empty
  2. Email field contains valid email address (according to this pattern implemented by the browser's native email input field) that doesn't contain more than 200 characters
  3. Issue reporter has been open for at least five seconds (or background tab has finished loading)

Assuming that an email was entered and that it takes a user more than five seconds from the time the issue reporter was opened to the time they finished entering the email address, it may depend on the Firefox version and email address that was used.

For reference, I tried testing it using the email address "foo@g" which appears to be sufficient for the browse to consider it valid.

comment:3 Changed 9 months ago by greiner

One potential issue I can see with the aforementioned email pattern is that it doesn't work for internationalized email addresses and domain names. So entering an email address such as 大学@example.com or foo@example.рф would not be considered valid.

Usually, such addresses would need to be converted to ASCII (e.g. xn--pss25c@example.com or foo@example.xn--p1ai) before running the validation on them.

comment:4 Changed 4 months ago by greiner

  • Resolution set to duplicate
  • Status changed from new to closed

Closing this ticket in favor of ui#525.

Note: See TracTickets for help on using tickets.