Opened 5 months ago

Closed 5 months ago

#7351 closed change (duplicate)

Create test cases for Generic Block and Generic Hide

Reported by: ubernitt Assignee: Ross
Priority: P4 Milestone:
Module: Websites Keywords:
Cc: fhd, Ross, sebastian Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by Ross)

Background

As a dev or a DP partner, I want to have a test scenario for Generic Block and Generic Hide in the test pages in order to improve testing of our products and implementations

What to change

For generic hide:

  • Add a test page with two target elements.
  • Element 1 is hidden with a specific filter. Element 2 is hidden with a generic filter.
  • Add a filter to add exceptions to the generic element.
  • Add the same elements, but inside a frame, for testing frame behaviour.

For generic block:

  • Add a test page with two target images.
  • Image 1 is hidden with a specific filter ($domain=). Image 2 is hidden with a generic filter.
  • Add a filter to add exceptions to the generic image.
  • Add the same images, but inside a frame, for testing frame behaviour.

Change History (4)

comment:1 Changed 5 months ago by ubernitt

Links to DP-94 in the DP Team Jira board

comment:2 Changed 5 months ago by Ross

  • Cc Ross sebastian added
  • Component changed from Unknown to Websites
  • Description modified (diff)
  • Priority changed from Unknown to P4
  • Tester changed from Rraceanu to Unknown

Added specific changes required. There are more edge cases that could be covered, but this covers basic functionality for now.

comment:3 Changed 5 months ago by ubernitt

I had to realize, this is a duplicate of #7163. @Ross, please choose one to drop it.

comment:4 Changed 5 months ago by Ross

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.