Opened 17 months ago

Closed 16 months ago

Last modified 16 months ago

#7387 closed defect (fixed)

Onboarding shown again after upgrade

Reported by: aboegler Assignee: diegocarloslima
Priority: P3 Milestone: Adblock-Browser-for-Android-1.5.0
Module: Adblock-Browser-for-Android Keywords:
Cc: diegocarloslima Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/30033567/

Description

Environment

Samsung Galaxy A7 (2018), Android 8.0, Adblock Browser 1.4.0 and 1.5.0.

How to reproduce

  1. Install ABB 1.4.0 from the Play Store.
  2. Launch ABB 1.4.0
  3. Go through onboarding by tapping "Only one more step", then "Finish"
  4. Install ABB 1.5.0
  5. Launch ABB 1.5.0

Observed behaviour

The onboarding slides are displayed again, requiring tapping "Only one more step" and "Finish" one more time.

Expected behaviour

The onboarding slides should not be displayed, and the browser should return to its previously opened page (e.g. new tab page).

Change History (6)

comment:1 Changed 17 months ago by diegocarloslima

This is due to the fact that Mozilla changed the first run preference name on FF57. Thus, the browser thinks the user didnt see the first run before and shows it again

comment:2 Changed 17 months ago by diegocarloslima

  • Owner set to diegocarloslima

comment:3 Changed 17 months ago by diegocarloslima

  • Priority changed from Unknown to P3
  • Ready set
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 16 months ago by abpbot

A commit referencing this issue has landed:
Issue 7387 - Onboarding shown again after upgrade

comment:5 Changed 16 months ago by diegocarloslima

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 16 months ago by aboegler

QA LGTM

Note: See TracTickets for help on using tickets.