Opened 7 months ago

Last modified 5 months ago

#7395 new change

Make abpbot compatible with Python 3

Reported by: kvas Assignee: atudor
Priority: Unknown Milestone:
Module: Sitescripts Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Background

Python 2 will cease being supported at the start of 2020. We have decided to migrate the code and deployments to Python 3 before that date. abpbot is a good small chunk of code that we can start with.

What to change

Make abpbot run on Python 3 (while still being compatible with Python 2, this makes the logistics of migration easier). Ideally it would be good to also add tests where the changes are not purely mechanical (for example print a to print(a) is purely mechanical but changing the code that deals with unicode might not be purely mechanical).

Change History (1)

comment:1 Changed 5 months ago by atudor

  • Owner set to atudor
Note: See TracTickets for help on using tickets.