Opened 5 weeks ago

Closed 5 weeks ago

Last modified 5 weeks ago

#7463 closed defect (rejected)

Background page errors in Chromium 49.0

Reported by: BrentM Assignee: kzar
Priority: P2 Milestone:
Module: Platform Keywords:
Cc: mjethani, sebastian, kzar Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://gitlab.com/eyeo/adblockplus/adblockpluschrome/merge_requests/64

Description (last modified by kzar)

Environment

Mac OS 10.14.4
Chromium 49.0.2623.0 (64-bit)
ABP version 3.5.1

How to reproduce

1 Install ABP 3.5.1 in Chromium
2 Navigate to any website

Observed behaviour ==

Requests that should be blocked are not (the blocked count on sites never increases)

Several errors are shown on the background page

Expected behaviour

Requests should be blocked

Below are some of the JS errors from the background page:

extensions::uncaught_exception_handler:8 Error in response to tabs.query: Error: Invalid value for argument 1. Property 'imageData': Value does not match any valid type choices.

at Object.value [as setIcon] (chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/polyfill.js:128:14)
at Promise.all.Object.keys.map.e (chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/ext/background.js:374:40)
at Object._applyChanges (chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/ext/background.js:345:53)
at Object._addChange (chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/ext/background.js:417:14)
at Object.setIconImageData (chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/ext/background.js:435:12)
at setIcon (chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/lib/adblockplus.js:11785:26)
at Object.value (chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/polyfill.js:115:23)
at filterNotifier.on (chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/lib/adblockplus.js:5123:16)
at EventEmitter.emit (chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/lib/adblockplus.js:4902:9)
at setTimeout (chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/lib/adblockplus.js:8259:20)handler @ extensions::uncaught_exception_handler:8(anonymous function) @ extensions::uncaught_exception_handler:100safeCallbackApply @ extensions::sendRequest:23handleResponse @ extensions::sendRequest:72

extensions::uncaught_exception_handler:8 Error in event handler for webRequest.onBeforeRequest/2: ReferenceError: updatePageFrameStructure is not defined

at browser.webRequest.onBeforeRequest.addListener.details (chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/ext/background.js:309:7)handler @ extensions::uncaught_exception_handler:8(anonymous function) @ extensions::uncaught_exception_handler:100EventImpl.dispatch_ @ extensions::event_bindings:376dispatchArgs @ extensions::event_bindings:243dispatchEvent @ extensions::event_bindings:252

extensions::uncaught_exception_handler:8 Error in event handler for runtime.onMessage: TypeError: Cannot read property 'injectedStyleSheets' of undefined

at updateFrameStyles (chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/lib/adblockplus.js:12846:19)
at port.on (chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/lib/adblockplus.js:12979:19)
at Object._onMessage (chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/lib/adblockplus.js:4512:22)
at Object._dispatch (chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/ext/common.js:41:22)
at browser.runtime.onMessage.addListener (chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/ext/background.js:555:26)
at wrapper (chrome-extension://cfhdojbkjhnklbpkdaibdccddilifddb/polyfill.js:188:20)handler @ extensions::uncaught_exception_handler:8(anonymous function) @ extensions::uncaught_exception_handler:100EventImpl.dispatch_ @ extensions::event_bindings:376EventImpl.dispatch @ extensions::event_bindings:393target.(anonymous function) @ extensions::SafeBuiltins:19publicClass.(anonymous function) @ extensions::utils:94messageListener @ extensions::messaging:189target.(anonymous function) @ extensions::SafeBuiltins:19EventImpl.dispatchToListener @ extensions::event_bindings:387target.(anonymous function) @ extensions::SafeBuiltins:19publicClass.(anonymous function) @ extensions::utils:94EventImpl.dispatch_ @ extensions::event_bindings:371EventImpl.dispatch @ extensions::event_bindings:393target.(anonymous function) @ extensions::SafeBuiltins:19publicClass.(anonymous function) @ extensions::utils:94dispatchOnMessage @ extensions::messaging:320

Attachments (2)

Screen Shot 2019-04-16 at 8.44.39 AM.png (254.7 KB) - added by BrentM 5 weeks ago.
Screen Shot 2019-04-16 at 8.32.40 AM.png (25.5 KB) - added by BrentM 5 weeks ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 5 weeks ago by sebastian

  • Cc mjethani sebastian added
  • Component changed from Unknown to Platform
  • Ready set

comment:2 Changed 5 weeks ago by mjethani

  • Owner set to mjethani

comment:3 Changed 5 weeks ago by mjethani

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 follow-up: Changed 5 weeks ago by kzar

  • Owner changed from mjethani to kzar

(Reassigning myself as discussed in IRC.)

I can't reproduce this on Chrome 49.0.2623.75 (64-bit), both for 3.5.1 (current master) and the current head of next branch which includes my changes to this code for #7338. I've both smoke tested basic Adblock Plus functionality, and tested icon animations work.

So could you clarify how I can reproduce this Brent? You're running the current release version of Adblock Plus right?

comment:5 Changed 5 weeks ago by kzar

  • Description modified (diff)
  • Ready unset

comment:6 Changed 5 weeks ago by kzar

  • Cc kzar added

comment:7 in reply to: ↑ 4 Changed 5 weeks ago by BrentM

Replying to kzar:

(Reassigning myself as discussed in IRC.)

I can't reproduce this on Chrome 49.0.2623.75 (64-bit), both for 3.5.1 (current master) and the current head of next branch which includes my changes to this code for #7338. I've both smoke tested basic Adblock Plus functionality, and tested icon animations work.

So could you clarify how I can reproduce this Brent? You're running the current release version of Adblock Plus right? Yes (3.5.1) from the CWS installed Chromium Version 49.0.2623.0 (64-bit) on a mac. Our new QA tester, Alya, was the one who notified me of the issue in AdBlock built with ABP version 3.5.1, and she saw similar JavaScript errors when testing on in Chrome 49 on a mac.

As far reproducing the issue, I just installed the extension in Chromium on my mac from the CWS. As soon as I installed the extension and checked the background page, I see two JavaScript errors. If I navigate to any website, I see a few different JS errors. I'll attach a screen shot of the background page.

Last edited 5 weeks ago by BrentM (previous) (diff)

Changed 5 weeks ago by BrentM

Changed 5 weeks ago by BrentM

comment:8 follow-up: Changed 5 weeks ago by kzar

So you talk about Chromium 49.0, do you mean Chrome 49.0? Is "49.0" the full version number?

comment:9 in reply to: ↑ 8 ; follow-up: Changed 5 weeks ago by BrentM

Replying to kzar:

So you talk about Chromium 49.0, do you mean Chrome 49.0? Is "49.0" the full version number?

Version 49.0.2623.0 (64-bit) on my mac (and it is Chromium, not Chrome). I can never find older versions of Chrome, only Chromium.

comment:10 Changed 5 weeks ago by kzar

Cool alright, just checking. Odd that I can't reproduce this then, perhaps between 49.0.2623.0 and 49.0.2623.75 they fixed something? I'll keep trying to reproduce it and update the issue when I get a chance. Thanks for taking the time to file this.

comment:11 Changed 5 weeks ago by Ross

As Dave says, it seems something was fixed between 49.0.2623.0 and 49.0.2623.75. We usually test with 49.0.2623.75 here, as thats what is available on the testing machine provider.

I'm guessing most people still on Windows XP (which is why we support Chrome 49), would have at least updated to the latest Chrome available to them, which would be 49.0.2623.XXX? It's something we should probably try out when we have time.

@BrentM Where do you get your Chromium installer for 49.0.2623.0 on Mac?

comment:12 in reply to: ↑ 9 Changed 5 weeks ago by mjethani

Replying to BrentM:

Version 49.0.2623.0 (64-bit) on my mac

I happen to have this exact version, also on macOS, and I can also reproduce the issue.

comment:13 Changed 5 weeks ago by kzar

In that case, do either of you have a link to this exact version of Chrome that you're using? I'd still like to try to reproduce the problem.

comment:14 Changed 5 weeks ago by mjethani

I got my version of Chrome 49 from here: https://www.chromium.org/getting-involved/download-chromium ("Downloading old builds of Chrome / Chromium"). Unfortunately it didn't seem to work anymore when I had tried a few days ago, but you could give it a go.

Last edited 5 weeks ago by mjethani (previous) (diff)

comment:15 Changed 5 weeks ago by BrentM

I used the same site as noted above (https://www.chromium.org/getting-involved/download-chromium), which was a pain, and half broken.

Almost all of our Chrome 49 users are on version 49.0.2623.112, so I wanted to find the same version, but I couldn't.

I'm fairly certain this is the link to version 49.0.2623.0 of Chromium for mac that I have installed on my mac ->

https://commondatastorage.googleapis.com/chromium-browser-snapshots/index.html?prefix=Mac/383690/

comment:16 Changed 5 weeks ago by sebastian

If this is indeed a Chrome bug that only existed between builds (but not in the latest build of any major version), I wonder if we even want to address it? We cannot possibly support every single build that ever existed. Specifically, x.x.x.0 looks rather suspicious, i.e. it most certainly was never officially released, as this would imply that this version of Chrome made it through the whole release cycle without any changes/fixes on the way, as far as I understand their versioning scheme.

Last edited 5 weeks ago by sebastian (previous) (diff)

comment:17 Changed 5 weeks ago by kzar

  • Resolution set to rejected
  • Status changed from reviewing to closed

Yea, I agree, I don't think we do want to address this. There's always webmate for testing if you guys can't find a less buggy copy of Chrome 49. If you'd like the Linux copy I test with just drop me an email.

comment:18 Changed 5 weeks ago by BrentM

Thanks for looking into this.

Note: See TracTickets for help on using tickets.