Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#7474 closed defect (duplicate)

DevTools ABP panel request filtering doesn't work properly

Reported by: scuturic Assignee:
Priority: P1 Milestone:
Module: User-Interface Keywords:
Cc: arthur, greiner Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Windows 10 Pro, Version 10.0.17763 Build 17763
Google Chrome Version 74.0.3729.169 (Official Build) (64-bit)
Adblock Plus development build 3.5.2.2320

How to reproduce

  1. Go to https://edition.cnn.com/europe/live-news/theresa-may-resignation-announcement-0524-gbr-intl/index.html
  2. Open DevTools and go to ABP panel and hit ctrl-F to open the "Find" field at the bottom
  3. Search for any request, "google", "outbrain", "doubleclick" etc.

...

Observed behaviour

Requests are not filtered properly, sometimes only whitelisted ones appear, sometimes only blocked.

Expected behaviour

Requests should be filtered normally, depending on user selection of the drop down menu (all, blocked, whitelisted).

Change History (6)

comment:1 Changed 5 months ago by greiner

  • Cc greiner added
  • Component changed from Unknown to User-Interface

comment:2 follow-up: Changed 5 months ago by greiner

I cannot reproduce the issue. At least I'm not getting any blocked requests when searching for any of those terms and the whitelisted requests appear consistently. If you have other reproduction steps I could try, please let me know.

Does the same issue occur in the stable build or only in the development build?

comment:3 in reply to: ↑ 2 Changed 5 months ago by scuturic

Replying to greiner:

I cannot reproduce the issue. At least I'm not getting any blocked requests when searching for any of those terms and the whitelisted requests appear consistently. If you have other reproduction steps I could try, please let me know.

Does the same issue occur in the stable build or only in the development build?

Maybe I described it badly. If I leave the selection to "all" in the drop down menu and type any keyword to filter the requests (doubleclick is a good example), I only get whitelisted requests and I should get all: blocked, whitelisted, and the ones that are neither.

If I scroll through the list I can see some doubleclick requests blocked but they are not shown when I type the keyword.

Could it be the Fixed #4 - Expose ElemHideException filters in devtools panel change?

Doesn't happen in the stable build.

comment:4 Changed 5 months ago by greiner

  • Owner set to greiner
  • Priority changed from Unknown to P1
  • Ready set

Thanks for the additional details and for clarifying that it's a regression. I'm definitely seeing some strange behavior with the search filtering now and will look into it.

Could it be the Fixed #4 - Expose ElemHideException filters in devtools panel change?

IIRC no changes to the UI were made for this change so I wouldn't expect it at this point. What we did do, for example, is make the DevTools panel translatable which was quite a significant change. However, I'll have to further investigate to identify the root cause.

comment:5 Changed 5 months ago by greiner

  • Resolution set to duplicate
  • Status changed from new to closed

Moving this ticket to ui#430 and closing it as duplicate since we recently stopped mirroring tickets on here. Please continue to track its progress over there.

comment:6 Changed 5 months ago by greiner

  • Owner greiner deleted
Note: See TracTickets for help on using tickets.