Opened 5 months ago

Closed 4 months ago

#7490 closed defect (rejected)

List compilation failed error

Reported by: joh Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: sebastian Blocked By:
Blocking: Platform: Safari
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Safari 12.1 (13607.1.40.1.5)
Mac OS 10.13.6

ABP 1.12.5

Adblock Warning Removal List
EasyList (minified)

How to reproduce

It seems random but it maybe when it updates the lists?
If I manually update the list I get the error

Observed behaviour

Error Message see attached

Attachments (1)

006tNc79gy1g4c98so8jrj30b903gjra.jpg (5.0 KB) - added by joh 5 months ago.

Download all attachments as: .zip

Change History (3)

Changed 5 months ago by joh

comment:1 Changed 5 months ago by greiner

  • Cc sebastian added

As mentioned in the release notes for Adblock Plus 2.0, starting with Safari 12, you'll need at least Adblock Plus 2.0 because Safari no longer supports the features that allowed us to do the ad blocking ourselves but instead requires us to use their ad blocking engine.

Therefore please make sure to get the latest version of Adblock Plus for Safari.

@Sebastian Please correct me if I'm wrong and otherwise close this ticket.

comment:2 Changed 4 months ago by sebastian

  • Resolution set to rejected
  • Status changed from new to closed

Yes, Adblock Plus 1.* for Safari is outdated, and was never compatible with Safari 12. You can get the latest compatible version here.

Note: See TracTickets for help on using tickets.