Opened 3 months ago

Closed 3 months ago

Last modified 6 weeks ago

#7512 closed defect (rejected)

Previously invalid rule is now valid

Reported by: BrentM Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: Ross, sebastian, greiner Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by BrentM)

Environment

Windows 10
Chrome 76.0.3809.100
ABP 3.6.2

How to reproduce

  1. Open the ABP Options page
  2. Click Advanced
  3. Enter the following rule into the 'My Filter List' section:
  ^^SDKLS###!!!!!!! (&^()%^^$%$jhdrfs

Observed behaviour

  1. Rule is saved

Expected behaviour

Previously, in ABP 3.5.2 when the above rule was saved, an error was generated, and the rule wasn't saved. The error was:

Line 1: '#!!!!!!! (&()%$%$jhdrfs' is not a valid CSS selector

Change History (4)

comment:1 Changed 3 months ago by BrentM

  • Description modified (diff)

comment:2 follow-up: Changed 3 months ago by greiner

  • Cc greiner added

When we moved the filter validation logic we also decided to drop the CSS selector validation while doing so because with manifest v3 we won't be able to use the DOM API in the background page (i.e. in Adblock Plus Core) anymore (see #7423).

That being said, we could try to prevent the user from adding such filters in the UI because there we retain access to the DOM API, if we think it adds enough value.

comment:3 in reply to: ↑ 2 Changed 3 months ago by kzar

  • Resolution set to rejected
  • Status changed from new to closed

Replying to greiner:

That being said, we could try to prevent the user from adding such filters in the UI because there we retain access to the DOM API, if we think it adds enough value.

Good point, sounds like a good idea to me so I've filed https://gitlab.com/eyeo/adblockplus/abpui/adblockplusui/issues/558

Otherwise I don't think there's much we can do here, so I'll close this.

comment:4 Changed 2 months ago by booms1

spam

Last edited 6 weeks ago by kzar (previous) (diff)
Note: See TracTickets for help on using tickets.