Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#974 closed defect (fixed)

'atlthunk.lib' is not found by linker

Reported by: sergz Assignee: sergz
Priority: P4 Milestone: Adblock-Plus-1.2-for-Internet-Explorer
Module: Adblock-Plus-for-Internet-Explorer Keywords:
Cc: Blocked By:
Blocking: Platform: Internet Explorer
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6221488373891072/

Description

Environment

MS Visual Studio Ultimate 2012 Update 4

How to reproduce

  1. run adblockplusie\createsolution.bat
  2. try to compile AdblockPlus project

Observed behaviour

The link error

LINK : fatal error LNK1104: cannot open file 'atlthunk.lib'

Expected behaviour

Successfully link.

Solution

Looks like this library is from Windows Driver Kit (WDK) and it's absent and is not used by ATL in MSVS2012 (not express), so just don't use it.

Change History (4)

comment:1 Changed 5 years ago by oleksandr

  • Component changed from Unknown to Adblock-Plus-for-Internet-Explorer
  • Owner set to sergz
  • Priority changed from Unknown to P4
  • Ready set

comment:2 Changed 5 years ago by oleksandr

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 5 years ago by sergz

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:4 Changed 5 years ago by trev

  • Milestone set to Adblock-Plus-for-Internet-Explorer-1.2

This was apparently fixed in https://hg.adblockplus.org/adblockplusie/rev/59f326086f3e meaning that this change made it into 1.2 release.

Note: See TracTickets for help on using tickets.